What’s Vulnerable › Vulnerabilities
CVE-2021-43836: PHP file inclusion in the Sulu admin panel
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-15 · updated 2026-06-17
- Weakness: CWE-22
Description
Sulu is an open-source PHP content management system based on the Symfony framework. In affected versions an attacker can read arbitrary local files via a PHP file include. In a default configuration this also leads to remote code execution. The problem is patched with the Versions 1.6.44, 2.2.18, 2.3.8, 2.4.0. For users unable to upgrade overwrite the service `sulu_route.generator.expression_token_provider` and wrap the translator before passing it to the expression language.
Affected products
- sulu: before 1.6.44; from 2.0.0 before 2.2.18; from 2.3.0 before 2.3.8; 2.4.0-rc1 — fixed in 1.6.44, 2.2.18, 2.3.8
How to fix
Upgrade to a fixed version: sulu 1.6.44, 2.2.18, 2.3.8. Check the vendor advisory for mitigations.
References
- https://github.com/sulu/sulu/commit/9c948f9ce350c68b53af8c3910e2cefc7f722b54
- https://github.com/sulu/sulu/security/advisories/GHSA-vx6j-pjrh-vgjh
- https://github.com/sulu/sulu/commit/9c948f9ce350c68b53af8c3910e2cefc7f722b54
- https://github.com/sulu/sulu/security/advisories/GHSA-vx6j-pjrh-vgjh
Get alerted when CVE-2021-43836 or the next vulnerability affects your stack