What’s Vulnerable › Vulnerabilities
CVE-2021-43857: Gerapy may contain remote code execution vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 55.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-78
Description
Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.
Affected products
- Gerapy: before 0.9.8 — fixed in 0.9.8
How to fix
Upgrade to a fixed version: Gerapy 0.9.8. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/165459/Gerapy-0.9.7-Remote-Code-Execution.html
- https://github.com/Gerapy/Gerapy/commit/49bcb19be5e0320e7e1535f34fe00f16a3cf3b28
- https://github.com/Gerapy/Gerapy/issues/219
- https://github.com/Gerapy/Gerapy/security/advisories/GHSA-9w7f-m4j4-j3xw
- http://packetstormsecurity.com/files/165459/Gerapy-0.9.7-Remote-Code-Execution.html
- https://github.com/Gerapy/Gerapy/commit/49bcb19be5e0320e7e1535f34fe00f16a3cf3b28
- https://github.com/Gerapy/Gerapy/issues/219
- https://github.com/Gerapy/Gerapy/security/advisories/GHSA-9w7f-m4j4-j3xw
Get alerted when CVE-2021-43857 or the next vulnerability affects your stack