What’s Vulnerable › Vulnerabilities
CVE-2021-43862: Self XSS on user input
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-30 · updated 2026-06-17
- Weakness: CWE-80
Description
jQuery Terminal Emulator is a plugin for creating command line interpreters in your applications. Versions prior to 2.31.1 contain a low impact and limited cross-site scripting (XSS) vulnerability. The code for XSS payload is always visible, but an attacker can use other techniques to hide the code the victim sees. If the application uses the `execHash` option and executes code from URL, the attacker can use this URL to execute their code. The scope is limited because the javascript attribute used is added to span tag, so no automatic execution like with `onerror` on images is possible. This issue is fixed in version 2.31.1. As a workaround, the user can use formatting that wrap whole user input and its no op. The code for this workaround is available in the GitHub Security Advisory. The fix will only work when user of the library is not using different formatters (e.g. to highlight code in different way).
Affected products
- jcubic jquery.terminal: before 2.31.1 — fixed in 2.31.1
How to fix
Upgrade to a fixed version: jcubic jquery.terminal 2.31.1. Check the vendor advisory for mitigations.
References
- https://github.com/jcubic/jquery.terminal/commit/77eb044d0896e990d48a9157f0bc6648f81a84b5
- https://github.com/jcubic/jquery.terminal/issues/727
- https://github.com/jcubic/jquery.terminal/releases/tag/2.31.1
- https://github.com/jcubic/jquery.terminal/security/advisories/GHSA-x9r5-jxvq-4387
- https://github.com/jcubic/jquery.terminal/commit/77eb044d0896e990d48a9157f0bc6648f81a84b5
- https://github.com/jcubic/jquery.terminal/issues/727
- https://github.com/jcubic/jquery.terminal/releases/tag/2.31.1
- https://github.com/jcubic/jquery.terminal/security/advisories/GHSA-x9r5-jxvq-4387
Get alerted when CVE-2021-43862 or the next vulnerability affects your stack