What’s Vulnerable › Vulnerabilities
CVE-2021-43940
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-15 · updated 2026-06-17
- Weakness: CWE-427
Description
Affected versions of Atlassian Confluence Server and Data Center allow authenticated local attackers to achieve elevated privileges on the local system via a DLL Hijacking vulnerability in the Confluence installer. This vulnerability only affects installations of Confluence Server and Data Center on Windows. The affected versions are before version 7.4.10, and from version 7.5.0 before 7.12.3.
Affected products
- Atlassian Confluence Data Center: before 7.4.10; from 7.5.0 before 7.12.3 — fixed in 7.12.3, 7.4.10
- Atlassian Confluence Data Center: before 7.4.10; from 7.5.0 before 7.12.3 — fixed in 7.12.3, 7.4.10
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.12.3, 7.4.10; Atlassian Confluence Data Center 7.12.3, 7.4.10. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-66550
- https://jira.atlassian.com/browse/CONFSERVER-66550
Get alerted when CVE-2021-43940 or the next vulnerability affects your stack