What’s Vulnerable › Vulnerabilities
CVE-2021-43958
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-16 · updated 2026-06-17
- Weakness: CWE-307
Description
Various rest resources in Fisheye and Crucible before version 4.8.9 allowed remote attackers to brute force user login credentials as rest resources did not check if users were beyond their max failed login limits and therefore required solving a CAPTCHA in addition to providing user credentials for authentication via a improper restriction of excess authentication attempts vulnerability.
Affected products
- Atlassian Crucible: before 4.8.9 — fixed in 4.8.9
- Atlassian Fisheye: before 4.8.9 — fixed in 4.8.9
How to fix
Upgrade to a fixed version: Atlassian Crucible 4.8.9; Atlassian Fisheye 4.8.9. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CRUC-8523
- https://jira.atlassian.com/browse/FE-7387
- https://jira.atlassian.com/browse/CRUC-8523
- https://jira.atlassian.com/browse/FE-7387
Get alerted when CVE-2021-43958 or the next vulnerability affects your stack