What’s Vulnerable › Vulnerabilities
CVE-2021-44053: Reflected XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability has been reported to affect QNAP device running QTS, QuTS hero and QuTScloud. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions of QTS, QuTS hero and QuTScloud: QTS 4.5.4.1991 build 20220329 and later QTS 5.0.0.1986 build 20220324 and later QuTS hero h5.0.0.1986 build 20220324 and later QuTS hero h4.5.4.1971 build 20220310 and later QuTScloud c5.0.1.1949 and later
Affected products
- QNAP QTS: from 5.0.0.1716 before 5.0.0.1986; from 4.3.3.0174 before 4.3.3.1945; from 4.3.4.0899 before 4.3.4.1976; from 4.3.6.0895 before 4.3.6.1965; from 4.4.0.0883 before 4.5.4.1991; 4.2.6-build_20170517, 4.2.6-build_20190322, 4.2.6-build_20190730, 4.2.6-build_20190921, 4.2.6-build_20191107, 4.2.6-build_20200109 (+5) — fixed in 4.3.3.1945, 4.3.4.1976, 4.3.6.1965, 4.5.4.1991, 5.0.0.1986
- QNAP Systems Inc. QuTS hero: before h4.5.4.1771; from h5.0.0.1772 before h5.0.0.1986 — fixed in h4.5.4.1771, h5.0.0.1986
- QNAP Systems Inc. QuTScloud: before c5.0.1.1998 — fixed in c5.0.1.1998
How to fix
Upgrade to a fixed version: QNAP QTS 4.3.3.1945, 4.3.4.1976, 4.3.6.1965, 4.5.4.1991; QNAP Systems Inc. QuTS hero h4.5.4.1771, h5.0.0.1986; QNAP Systems Inc. QuTScloud c5.0.1.1998. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-22-16
- https://www.qnap.com/en/security-advisory/qsa-22-16
Get alerted when CVE-2021-44053 or the next vulnerability affects your stack