What’s Vulnerable › Vulnerabilities
CVE-2021-44140: Arbitrary file deletion on logout
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-24 · updated 2026-06-17
- Weakness: CWE-276
Description
Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those files are reachable to the user running the JSPWiki instance. Apache JSPWiki users should upgrade to 2.11.0 or later.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.11.0 — fixed in 2.11.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.11.0. Check the vendor advisory for mitigations.
References
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2021-44140
- https://lists.apache.org/thread/5qglpjdhvobppx7j550lf1sk28f6011t
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2021-44140
- https://lists.apache.org/thread/5qglpjdhvobppx7j550lf1sk28f6011t
Get alerted when CVE-2021-44140 or the next vulnerability affects your stack