What’s Vulnerable › Vulnerabilities
CVE-2021-44141
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-21 · updated 2026-06-17
- Weakness: CWE-200
Description
All versions of Samba prior to 4.15.5 are vulnerable to a malicious client using a server symlink to determine if a file or directory exists in an area of the server file system not exported under the share definition. SMB1 with unix extensions has to be enabled in order for this attack to succeed.
Affected products
- Fedoraproject Fedora: 34, 35
- RedHat Storage: 3.0
- Samba: before 4.15.5 — fixed in 4.15.5
How to fix
Upgrade to a fixed version: Samba 4.15.5. Check the vendor advisory for mitigations.
References
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2021-44141.html
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2021-44141.html
Get alerted when CVE-2021-44141 or the next vulnerability affects your stack