What’s Vulnerable › Vulnerabilities
CVE-2021-44223
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 29.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-25 · updated 2026-06-17
Description
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
Affected products
- WordPress: before 5.8 — fixed in 5.8
How to fix
Upgrade to a fixed version: WordPress 5.8. Check the vendor advisory for mitigations.
References
- https://make.wordpress.org/core/2021/06/29/introducing-update-uri-plugin-header-in-wordpress-5-8/
- https://vavkamil.cz/2021/11/25/wordpress-plugin-confusion-update-can-get-you-pwned/
- https://make.wordpress.org/core/2021/06/29/introducing-update-uri-plugin-header-in-wordpress-5-8/
- https://vavkamil.cz/2021/11/25/wordpress-plugin-confusion-update-can-get-you-pwned/
Get alerted when CVE-2021-44223 or the next vulnerability affects your stack