What’s Vulnerable › Vulnerabilities

CVE-2021-44228: Apache Log4j2 Remote Code Execution Vulnerability

Description

Apache Log4j2 2.0-beta9 through 2.15.0 (excluding security releases 2.12.2, 2.12.3, and 2.3.1) JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.15.0, this behavior has been disabled by default. From version 2.16.0 (along with 2.12.2, 2.12.3, and 2.3.1), this functionality has been completely removed. Note that this vulnerability is specific to log4j-core and does not affect log4net, log4cxx, or other Apache Logging Services projects.

Summary

CVE-2021-44228 is a critical remote code execution flaw in Apache Log4j2 versions 2.0-beta9 through 2.15.0 (excluding 2.12.2, 2.12.3, and 2.3.1) where JNDI features do not protect against attacker-controlled endpoints, allowing arbitrary code execution via log messages. It is actively exploited, listed in CISA KEV, and has a public exploit with 100% EPSS probability. Affected products include Apache Log4j and various third-party applications like Apple Xcode, Bentley Synchro, and Cisco products. Apply updates to fixed versions (e.g., Log4j 2.15.0, 2.12.2, 2.3.1, or later) or remove affected assets; temporary mitigations are only acceptable until updates are available.

CVE-2021-44228 هو ثغرة تنفيذ تعليمات برمجية عن بُعد خطيرة في Apache Log4j2 الإصدارات من 2.0-beta9 إلى 2.15.0 (باستثناء 2.12.2 و2.12.3 و2.3.1) حيث لا تحمي ميزات JNDI من نقاط النهاية التي يتحكم بها المهاجم، مما يسمح بتنفيذ تعليمات برمجية عشوائية عبر رسائل السجل. الثغرة مستغلة بنشاط، ومدرجة في CISA KEV، ولها استغلال عام مع احتمال 100% وفق EPSS. تشمل المنتجات المتأثرة Apache Log4j وتطبيقات طرف ثالث مثل Apple Xcode وBentley Synchro ومنتجات Cisco. قم بتطبيق التحديثات للإصدارات المُصلحة (مثل Log4j 2.15.0 أو 2.12.2 أو 2.3.1 أو أحدث) أو إزالة الأصول المتأثرة؛ التخفيفات المؤقتة مقبولة فقط حتى توفر التحديثات.

Affected products

How to fix

Upgrade to a fixed version: Apache Log4j 2.12.2, 2.15.0, 2.3.1; Apple Xcode 13.3; Bentley Synchro 6.2.4.2; Bentley Synchro 4D 6.4.3.2; Cisco Advanced Malware Protection Virtual Private Cloud Appliance 3.5.4; Cisco Automated Subsea Tuning 2.1.0; Cisco Broadworks 2021.11_1.162; Cisco Business Process Automation (BPA) 3.0.000.115, 3.1.000.044, 3.2.000.009; Cisco Cloud Connect 12.6\(1\); Cisco Cloudcenter 4.10.0.16; Cisco Cloudcenter Cost Optimizer 5.5.2; Cisco Cloudcenter Suite Admin 5.3.1. Check the vendor advisory for mitigations.

In the news

References

Get alerted when CVE-2021-44228 or the next vulnerability affects your stack