What’s Vulnerable › Vulnerabilities
CVE-2021-4428: what3words Autosuggest Plugin Setting class-w3w-autosuggest-public.php enqueue_scripts information disclosure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 15.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-18 · updated 2026-06-17
- Weakness: CWE-200
Description
A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.
Affected products
- what3words Autosuggest Plugin: before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: what3words Autosuggest Plugin 4.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/what3words/wordpress-autosuggest-plugin/commit/dd59cbac5f86057d6a73b87007c08b8bfa0c32ac
- https://github.com/what3words/wordpress-autosuggest-plugin/pull/20
- https://github.com/what3words/wordpress-autosuggest-plugin/releases/tag/v4.0.1
- https://vuldb.com/?ctiid.234247
- https://vuldb.com/?id.234247
- https://github.com/what3words/wordpress-autosuggest-plugin/commit/dd59cbac5f86057d6a73b87007c08b8bfa0c32ac
- https://github.com/what3words/wordpress-autosuggest-plugin/pull/20
- https://github.com/what3words/wordpress-autosuggest-plugin/releases/tag/v4.0.1
- https://vuldb.com/?ctiid.234247
- https://vuldb.com/?id.234247
Get alerted when CVE-2021-4428 or the next vulnerability affects your stack