What’s Vulnerable › Vulnerabilities
CVE-2021-4434: Social Warfare <= 3.5.2 - Remote Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-17 · updated 2026-06-17
- Weakness: CWE-94
Description
The Social Warfare plugin for WordPress is vulnerable to Remote Code Execution in versions up to, and including, 3.5.2 via the 'swp_url' parameter. This allows attackers to execute code on the server.
Affected products
- warfareplugins Social Sharing Plugin – Social Warfare: before 3.5.3 — fixed in 3.5.3
How to fix
Upgrade to a fixed version: warfareplugins Social Sharing Plugin – Social Warfare 3.5.3. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/163680/WordPress-Social-Warfare-3.5.2-Remote-Code-Execution.html
- https://www.wordfence.com/threat-intel/vulnerabilities/id/98cf2a10-cc53-4479-87d1-71489f6a8c51?source=cve
- https://packetstormsecurity.com/files/163680/WordPress-Social-Warfare-3.5.2-Remote-Code-Execution.html
- https://www.wordfence.com/threat-intel/vulnerabilities/id/98cf2a10-cc53-4479-87d1-71489f6a8c51?source=cve
Get alerted when CVE-2021-4434 or the next vulnerability affects your stack