What’s Vulnerable › Vulnerabilities
CVE-2021-4441: spi: spi-zynq-qspi: Fix a NULL pointer dereference in zynq_qspi_exec_mem_op()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-22 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: spi: spi-zynq-qspi: Fix a NULL pointer dereference in zynq_qspi_exec_mem_op() In zynq_qspi_exec_mem_op(), kzalloc() is directly used in memset(), which could lead to a NULL pointer dereference on failure of kzalloc(). Fix this bug by adding a check of tmpbuf. This bug was found by a static analyzer. The analysis employs differential checking to identify inconsistent security operations (e.g., checks or kfrees) between two code paths and confirms that the inconsistent operations are not recovered in the current function or the callers, so they constitute bugs. Note that, as a bug found by static analysis, it can be a false positive or hard to trigger. Multiple researchers have cross-reviewed the bug. Builds with CONFIG_SPI_ZYNQ_QSPI=m show no new warnings, and our static analyzer no longer warns about this code.
Affected products
- Linux kernel: from 5.2 before 5.4.182; from 5.5 before 5.10.103; from 5.11 before 5.15.26; from 5.16 before 5.16.12; 5.17-rc1, 5.17-rc2, 5.17-rc3, 5.17-rc4, 5.17-rc5 — fixed in 5.10.103, 5.15.26, 5.16.12, 5.4.182
How to fix
Upgrade to a fixed version: Linux kernel 5.10.103, 5.15.26, 5.16.12, 5.4.182. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2efece1368aeee2d2552c7ec36aeb676c4d4c95f
- https://git.kernel.org/stable/c/3c32405d6474a21f7d742828e73c13e326dcae82
- https://git.kernel.org/stable/c/ab3824427b848da10e9fe2727f035bbeecae6ff4
- https://git.kernel.org/stable/c/b9dd08cbebe0c593c49bf86d2012a431494e54cb
- https://git.kernel.org/stable/c/df14d2bed8e2455878e046e67123d9ecb2e79056
Get alerted when CVE-2021-4441 or the next vulnerability affects your stack