What’s Vulnerable › Vulnerabilities
CVE-2021-44420: Potential bypass of an upstream access control based on URL paths in Django
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-08 · updated 2026-06-17
Description
In Django 2.2 before 2.2.25, 3.1 before 3.1.14, and 3.2 before 3.2.10, HTTP requests for URLs with trailing newlines could bypass upstream access control based on URL paths.
Affected products
- Canonical Ubuntu Linux: 20.04, 21.04, 21.10
- Debian Linux: 10.0, 11.0
- Django: from 2.2 before 2.2.25; from 3.1 before 3.1.14; from 3.2 before 3.2.10 — fixed in 2.2.25, 3.1.14, 3.2.10
- Fedoraproject Fedora: 35
- Red Hat Satellite 6: 6.0
- Pypi Django: from 2.2 before 2.2.25; from 3.1 before 3.1.14; from 3.2 before 3.2.10; 2.2, 2.2.1, 2.2.10, 2.2.11, 2.2.12, 2.2.13 (+43) — fixed in 2.2.25, 3.1.14, 3.2.10
How to fix
Upgrade to a fixed version: Django 2.2.25, 3.1.14, 3.2.10; Pypi Django 2.2.25, 3.1.14, 3.2.10. Check the vendor advisory for mitigations.
References
- https://docs.djangoproject.com/en/3.2/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B4SQG2EAF4WCI2SLRL6XRDJ3RPK3ZRDV/
- https://security.netapp.com/advisory/ntap-20211229-0006/
- https://www.djangoproject.com/weblog/2021/dec/07/security-releases/
- https://www.openwall.com/lists/oss-security/2021/12/07/1
- https://docs.djangoproject.com/en/3.2/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B4SQG2EAF4WCI2SLRL6XRDJ3RPK3ZRDV/
- https://security.netapp.com/advisory/ntap-20211229-0006/
- https://www.djangoproject.com/weblog/2021/dec/07/security-releases/
- https://www.openwall.com/lists/oss-security/2021/12/07/1
Get alerted when CVE-2021-44420 or the next vulnerability affects your stack