What’s Vulnerable › Vulnerabilities
CVE-2021-44451: API sensitive information leak
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-522
Description
Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.
Affected products
- Apache Superset: through 1.3.2
References
- https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkb
- https://lists.apache.org/thread/xww1pccs2ckb5506wrf1v4lmxg198vkb
Get alerted when CVE-2021-44451 or the next vulnerability affects your stack