What’s Vulnerable › Vulnerabilities
CVE-2021-44568
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-21 · updated 2026-06-17
- Weakness: CWE-787
Description
Two heap-overflow vulnerabilities exist in openSUSE/libsolv libsolv through 13 Dec 2020 in the decisionmap variable via the resolve_dependencies function at src/solver.c (line 1940 & line 1995), which could cause a remote Denial of Service.
Affected products
- OpenSUSE libsolv: before 0.7.17 — fixed in 0.7.17
How to fix
Upgrade to a fixed version: OpenSUSE libsolv 0.7.17. Check the vendor advisory for mitigations.
References
- https://github.com/openSUSE/libsolv/issues/425
- https://github.com/yangjiageng/PoC/blob/master/libsolv-PoCs/resolve_dependencies-1940
- https://github.com/yangjiageng/PoC/blob/master/libsolv-PoCs/resolve_dependencies-1995
- https://github.com/openSUSE/libsolv/issues/425
- https://github.com/yangjiageng/PoC/blob/master/libsolv-PoCs/resolve_dependencies-1940
- https://github.com/yangjiageng/PoC/blob/master/libsolv-PoCs/resolve_dependencies-1995
Get alerted when CVE-2021-44568 or the next vulnerability affects your stack