What’s Vulnerable › Vulnerabilities
CVE-2021-44649
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Django CMS 3.7.3 does not validate the plugin_type parameter while generating error messages for an invalid plugin type, resulting in a Cross Site Scripting (XSS) vulnerability. The vulnerability allows an attacker to execute arbitrary JavaScript code in the web browser of the affected user.
Affected products
- django CMS Association django-cms: from 3.4.0 before 3.4.7; from 3.5.0 before 3.5.4; from 3.6.0 before 3.6.1; from 3.7.0 before 3.7.4 — fixed in 3.4.7, 3.5.4, 3.6.1, 3.7.4
How to fix
Upgrade to a fixed version: django CMS Association django-cms 3.4.7, 3.5.4, 3.6.1, 3.7.4. Check the vendor advisory for mitigations.
References
- https://sahildhar.github.io/blogpost/Django-CMS-Reflected-XSS-Vulnerability/
- https://www.django-cms.org/en/blog/2020/07/22/django-cms-security-updates-1/
- https://sahildhar.github.io/blogpost/Django-CMS-Reflected-XSS-Vulnerability/
- https://www.django-cms.org/en/blog/2020/07/22/django-cms-security-updates-1/
Get alerted when CVE-2021-44649 or the next vulnerability affects your stack