What’s Vulnerable › Vulnerabilities
CVE-2021-44657
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-15 · updated 2026-06-17
Description
In StackStorm versions prior to 3.6.0, the jinja interpreter was not run in sandbox mode and thus allows execution of unsafe system commands. Jinja does not enable sandboxed mode by default due to backwards compatibility. Stackstorm now sets sandboxed mode for jinja by default.
Affected products
- Stackstorm: before 3.6.0 — fixed in 3.6.0
How to fix
Upgrade to a fixed version: Stackstorm 3.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/StackStorm/st2/pull/5359
- https://github.com/pallets/jinja/issues/549
- https://podalirius.net/en/articles/python-vulnerabilities-code-execution-in-jinja-templates/
- https://stackstorm.com/2021/12/16/stackstorm-v3-6-0-released/
- https://github.com/StackStorm/st2/pull/5359
- https://github.com/pallets/jinja/issues/549
- https://podalirius.net/en/articles/python-vulnerabilities-code-execution-in-jinja-templates/
- https://stackstorm.com/2021/12/16/stackstorm-v3-6-0-released/
Get alerted when CVE-2021-44657 or the next vulnerability affects your stack