What’s Vulnerable › Vulnerabilities

CVE-2021-44717

Description

Go before 1.16.12 and 1.17.x before 1.17.5 on UNIX allows write operations to an unintended file or unintended network connection as a consequence of erroneous closing of file descriptor 0 after file-descriptor exhaustion.

Affected products

How to fix

Upgrade to a fixed version: Go 1.16.12, 1.17.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-44717 or the next vulnerability affects your stack