What’s Vulnerable › Vulnerabilities
CVE-2021-44730: snapd could be made to escalate privileges and run programs as administrator
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-17 · updated 2026-06-17
- Weakness: CWE-59
Description
snapd 2.54.2 did not properly validate the location of the snap-confine binary. A local attacker who can hardlink this binary to another location to cause snap-confine to execute other arbitrary binaries and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1
Affected products
- Canonical Ltd. snapd: through 2.54.2
- Canonical Ubuntu Linux: 18.04, 20.04, 21.10
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 34, 35
References
- http://www.openwall.com/lists/oss-security/2022/02/18/2
- http://www.openwall.com/lists/oss-security/2022/02/23/1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QTBN7LLZISXIA4KU4UKDR27Q5PXDS2U/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XCGHG6LJAVJJ72TMART6A7N4Z6MSTGI7/
- https://ubuntu.com/security/notices/USN-5292-1
- https://www.debian.org/security/2022/dsa-5080
- http://www.openwall.com/lists/oss-security/2022/02/18/2
- http://www.openwall.com/lists/oss-security/2022/02/23/1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QTBN7LLZISXIA4KU4UKDR27Q5PXDS2U/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XCGHG6LJAVJJ72TMART6A7N4Z6MSTGI7/
- https://ubuntu.com/security/notices/USN-5292-1
- https://www.debian.org/security/2022/dsa-5080
Get alerted when CVE-2021-44730 or the next vulnerability affects your stack