What’s Vulnerable › Vulnerabilities
CVE-2021-44731: snapd could be made to escalate privileges and run programs as administrator
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-17 · updated 2026-06-17
- Weakness: CWE-362
Description
A race condition existed in the snapd 2.54.2 snap-confine binary when preparing a private mount namespace for a snap. This could allow a local attacker to gain root privileges by bind-mounting their own contents inside the snap's private mount namespace and causing snap-confine to execute arbitrary code and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1
Affected products
- Canonical Ltd. snapd: through 2.54.2
- Canonical Ubuntu Linux: 18.04, 20.04, 21.10
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 34, 35
References
- http://packetstormsecurity.com/files/170176/snap-confine-must_mkdir_and_open_with_perms-Race-Condition.html
- http://seclists.org/fulldisclosure/2022/Dec/4
- http://www.openwall.com/lists/oss-security/2022/02/18/2
- http://www.openwall.com/lists/oss-security/2022/02/23/1
- http://www.openwall.com/lists/oss-security/2022/02/23/2
- http://www.openwall.com/lists/oss-security/2022/11/30/2
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QTBN7LLZISXIA4KU4UKDR27Q5PXDS2U/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XCGHG6LJAVJJ72TMART6A7N4Z6MSTGI7/
- https://ubuntu.com/security/notices/USN-5292-1
- https://www.debian.org/security/2022/dsa-5080
- http://packetstormsecurity.com/files/170176/snap-confine-must_mkdir_and_open_with_perms-Race-Condition.html
- http://seclists.org/fulldisclosure/2022/Dec/4
Get alerted when CVE-2021-44731 or the next vulnerability affects your stack