What’s Vulnerable › Vulnerabilities
CVE-2021-44732
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-20 · updated 2026-06-17
- Weakness: CWE-415
Description
Mbed TLS before 3.0.1 has a double free in certain out-of-memory conditions, as demonstrated by an mbedtls_ssl_set_session() failure.
Affected products
- mbedtls: before 2.16.12; from 2.17.0 before 2.28.0 — fixed in 2.16.12, 2.28.0
- Debian Linux: 10.0
- TrustedFirmware Mbed TLS: 3.0.0, 3.0.0-preview1
How to fix
Upgrade to a fixed version: mbedtls 2.16.12, 2.28.0. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/829660
- https://github.com/ARMmbed/mbedtls/releases
- https://github.com/ARMmbed/mbedtls/releases/tag/v2.16.12
- https://github.com/ARMmbed/mbedtls/releases/tag/v2.28.0
- https://github.com/ARMmbed/mbedtls/releases/tag/v3.1.0
- https://lists.debian.org/debian-lts-announce/2022/12/msg00036.html
- https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2021-12
- https://bugs.gentoo.org/829660
- https://github.com/ARMmbed/mbedtls/releases
- https://github.com/ARMmbed/mbedtls/releases/tag/v2.16.12
- https://github.com/ARMmbed/mbedtls/releases/tag/v2.28.0
- https://github.com/ARMmbed/mbedtls/releases/tag/v3.1.0
Get alerted when CVE-2021-44732 or the next vulnerability affects your stack