What’s Vulnerable › Vulnerabilities

CVE-2021-44790: Possible buffer overflow when parsing multipart content in mod_lua of Apache HTTP Server 2.4.51 and earlier

Description

A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

Affected products

How to fix

Upgrade to a fixed version: Apache HTTP Server 2.4.52; Apple macOS 10.15.7, 11.6.6, 12.4; Tenable.sc 5.20.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-44790 or the next vulnerability affects your stack