What’s Vulnerable › Vulnerabilities

CVE-2021-44832: Apache Log4j2 vulnerable to RCE via JDBC Appender when attacker controls configuration

Description

Apache Log4j2 versions 2.0-beta7 through 2.17.0 (excluding security fix releases 2.3.2 and 2.12.4) are vulnerable to a remote code execution (RCE) attack when a configuration uses a JDBC Appender with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI data source names to the java protocol in Log4j2 versions 2.17.1, 2.12.4, and 2.3.2.

Affected products

How to fix

Upgrade to a fixed version: Apache Log4j 2.12.4, 2.17.1, 2.3.2; Oracle Corporation Communications BRM - Elastic Charging Engine 12.0.0.4.6; Oracle Communications Offline Mediation Controller 12.0.0.4.4; Maven Org.Apache.Logging.Log4j:Log4j-Core 2.3.2, 2.12.4, 2.17.1; Maven Org.Ops4j.Pax.Logging:Pax-Logging-Log4j2 1.9.2, 1.10.9, 1.11.13, 2.0.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-44832 or the next vulnerability affects your stack