What’s Vulnerable › Vulnerabilities
CVE-2021-44911
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-09 · updated 2026-06-17
- Weakness: CWE-79
Description
XE before 1.11.6 is vulnerable to Unrestricted file upload via modules/menu/menu.admin.controller.php. When uploading the Mouse over button and When selected button, there is no restriction on the file suffix, which leads to any file uploading to the files directory. Since .htaccess only restricts the PHP type, uploading HTML-type files leads to stored XSS vulnerabilities.
Affected products
- XpressEngine: before 1.11.6 — fixed in 1.11.6
How to fix
Upgrade to a fixed version: XpressEngine 1.11.6. Check the vendor advisory for mitigations.
References
- https://github.com/xpressengine/xe-core/issues/2434
- https://github.com/xpressengine/xe-core/issues/2434
Get alerted when CVE-2021-44911 or the next vulnerability affects your stack