What’s Vulnerable › Vulnerabilities
CVE-2021-45042
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-17 · updated 2026-06-17
Description
In HashiCorp Vault and Vault Enterprise before 1.7.7, 1.8.x before 1.8.6, and 1.9.x before 1.9.1, clusters using the Integrated Storage backend allowed an authenticated user (with write permissions to a kv secrets engine) to cause a panic and denial of service of the storage backend. The earliest affected version is 1.4.0.
Affected products
- HashiCorp Vault: from 1.4.0 before 1.7.7; from 1.8.0 before 1.8.6; 1.9.0 — fixed in 1.7.7, 1.8.6
How to fix
Upgrade to a fixed version: HashiCorp Vault 1.7.7, 1.8.6. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com/t/hcsec2-21-33-vault-s-kv-secrets-engine-with-integrated-storage-exposed-to-authenticated-denial-of-service/33157
- https://security.gentoo.org/glsa/202207-01
- https://www.hashicorp.com/blog/category/vault
- https://discuss.hashicorp.com/t/hcsec2-21-33-vault-s-kv-secrets-engine-with-integrated-storage-exposed-to-authenticated-denial-of-service/33157
- https://security.gentoo.org/glsa/202207-01
- https://www.hashicorp.com/blog/category/vault
Get alerted when CVE-2021-45042 or the next vulnerability affects your stack