What’s Vulnerable › Vulnerabilities
CVE-2021-45079
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-31 · updated 2026-06-17
- Weakness: CWE-476
Description
In strongSwan before 5.9.5, a malicious responder can send an EAP-Success message too early without actually authenticating the client and (in the case of EAP methods with mutual authentication and EAP-only authentication for IKEv2) even without server authentication.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04, 21.10
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Extra Packages For Enterprise Linux: 7.0, 8.0, 9.0
- Fedoraproject Fedora: 34, 35
- strongSwan: from 4.1.2 before 5.9.5 — fixed in 5.9.5
How to fix
Upgrade to a fixed version: strongSwan 5.9.5. Check the vendor advisory for mitigations.
References
- https://www.strongswan.org/blog/2022/01/24/strongswan-vulnerability-%28cve-2021-45079%29.html
- https://www.strongswan.org/blog/2022/01/24/strongswan-vulnerability-%28cve-2021-45079%29.html
Get alerted when CVE-2021-45079 or the next vulnerability affects your stack