What’s Vulnerable › Vulnerabilities
CVE-2021-45082
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-19 · updated 2026-06-17
- Weakness: CWE-77
Description
An issue was discovered in Cobbler before 3.3.1. In the templar.py file, the function check_for_invalid_imports can allow Cheetah code to import Python modules via the "#from MODULE import" substring. (Only lines beginning with #import are blocked.)
Affected products
- The cobbler Project cobbler: before 3.3.1 — fixed in 3.3.1
- Fedoraproject Fedora: 34, 35, 36
- openSUSE Backports: sle-15-sp3, sle-15-sp4
- openSUSE Factory: all versions
- SUSE Linux Enterprise Server: 11-sp3, 12, 15-sp2, 15-sp3
How to fix
Upgrade to a fixed version: The cobbler Project cobbler 3.3.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=1193678
- https://github.com/cobbler/cobbler/releases
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TEJN7CPW6YCHBFQPFZKGA6AVA6T5NPIW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Z5CSXQE7Q4TVDQJKFYBO4XDH3BZ7BLAR/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZCXMOUW4DH4DYWIJN44SMSU6R3CZDZBE/
- https://bugzilla.suse.com/show_bug.cgi?id=1193678
- https://github.com/cobbler/cobbler/releases
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TEJN7CPW6YCHBFQPFZKGA6AVA6T5NPIW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Z5CSXQE7Q4TVDQJKFYBO4XDH3BZ7BLAR/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZCXMOUW4DH4DYWIJN44SMSU6R3CZDZBE/
Get alerted when CVE-2021-45082 or the next vulnerability affects your stack