What’s Vulnerable › Vulnerabilities
CVE-2021-45086
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-16 · updated 2026-06-17
- Weakness: CWE-79
Description
XSS can occur in GNOME Web (aka Epiphany) before 40.4 and 41.x before 41.1 because a server's suggested_filename is used as the pdf_name value in PDF.js.
Affected products
- Debian Linux: 11.0
- GNOME Epiphany: before 40.4; from 41.0 before 41.1 — fixed in 40.4, 41.1
How to fix
Upgrade to a fixed version: GNOME Epiphany 40.4, 41.1. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/epiphany/-/issues/1612
- https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/1045
- https://www.debian.org/security/2022/dsa-5042
- https://gitlab.gnome.org/GNOME/epiphany/-/issues/1612
- https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/1045
- https://www.debian.org/security/2022/dsa-5042
Get alerted when CVE-2021-45086 or the next vulnerability affects your stack