What’s Vulnerable › Vulnerabilities
CVE-2021-45092
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 40.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-16 · updated 2026-06-17
Description
Thinfinity VirtualUI before 3.0 has functionality in /lab.html reachable by default that could allow IFRAME injection via the vpath parameter.
Affected products
- Cybelesoft Thinfinity Virtualui: before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: Cybelesoft Thinfinity Virtualui 3.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/166068/Thinfinity-VirtualUI-2.5.41.0-IFRAME-Injection.html
- https://github.com/cybelesoft/virtualui/issues/2
- http://packetstormsecurity.com/files/166068/Thinfinity-VirtualUI-2.5.41.0-IFRAME-Injection.html
- https://github.com/cybelesoft/virtualui/issues/2
Get alerted when CVE-2021-45092 or the next vulnerability affects your stack