What’s Vulnerable › Vulnerabilities

CVE-2021-45105: Apache Log4j2 does not always protect from infinite recursion in lookup evaluation

Description

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3 and 2.3.1) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0, 2.12.3, and 2.3.1.

Affected products

How to fix

Upgrade to a fixed version: Apache Log4j 2.12.3, 2.3.1; Oracle Communications Element Manager 9.0; Oracle Communications Session Report Manager 9.0; Oracle Communications Session Route Manager 9.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-45105 or the next vulnerability affects your stack