What’s Vulnerable › Vulnerabilities

CVE-2021-45115: Denial-of-service in Django

Description

An issue was discovered in Django 2.2 before 2.2.26, 3.2 before 3.2.11, and 4.0 before 4.0.1. UserAttributeSimilarityValidator incurred significant overhead in evaluating a submitted password that was artificially large in relation to the comparison values. In a situation where access to user registration was unrestricted, this provided a potential vector for a denial-of-service attack.

Affected products

How to fix

Upgrade to a fixed version: Django 2.2.26, 3.2.11, 4.0.1; Pypi Django 2.2.26, 3.2.11, 4.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-45115 or the next vulnerability affects your stack