What’s Vulnerable › Vulnerabilities
CVE-2021-45230: Apache Airflow: Creating DagRuns didn't respect Dag-level permissions in the Webserver
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-20 · updated 2026-06-17
Description
In Apache Airflow prior to 2.2.0. This CVE applies to a specific case where a User who has "can_create" permissions on DAG Runs can create Dag Runs for dags that they don't have "edit" permissions for.
Affected products
- Apache Airflow: from 1.10.0 through 1.10.15; from 2.0.0 before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.2.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/m778ojn0k595rwco4ht9wjql89mjoxnl
- https://lists.apache.org/thread/m778ojn0k595rwco4ht9wjql89mjoxnl
Get alerted when CVE-2021-45230 or the next vulnerability affects your stack