What’s Vulnerable › Vulnerabilities
CVE-2021-45232: security vulnerability on unauthorized access.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 86.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-306
Description
In Apache APISIX Dashboard before 2.10.1, the Manager API uses two frameworks and introduces framework `droplet` on the basis of framework `gin`, all APIs and authentication middleware are developed based on framework `droplet`, but some API directly use the interface of framework `gin` thus bypassing the authentication.
Affected products
- Apache Software Foundation Apache APISIX Dashboard: before 2.10.1 — fixed in 2.10.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX Dashboard 2.10.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/12/27/1
- https://lists.apache.org/thread/979qbl6vlm8269fopfyygnxofgqyn6k5
- http://www.openwall.com/lists/oss-security/2021/12/27/1
- https://lists.apache.org/thread/979qbl6vlm8269fopfyygnxofgqyn6k5
Get alerted when CVE-2021-45232 or the next vulnerability affects your stack