What’s Vulnerable › Vulnerabilities
CVE-2021-45329
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability exists in Gitea before 1.5.1 via the repository settings inside the external wiki/issue tracker URL field.
Affected products
- Gitea Open Source Git Server: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Gitea Open Source Git Server 1.5.1. Check the vendor advisory for mitigations.
References
- https://blog.gitea.io/2018/09/gitea-1.5.1-is-released/
- https://github.com/go-gitea/gitea/pull/4710
- https://blog.gitea.io/2018/09/gitea-1.5.1-is-released/
- https://github.com/go-gitea/gitea/pull/4710
Get alerted when CVE-2021-45329 or the next vulnerability affects your stack