What’s Vulnerable › Vulnerabilities
CVE-2021-45467
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 70.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-26 · updated 2026-06-17
- Weakness: CWE-862
Description
In CWP (aka Control Web Panel or CentOS Web Panel) before 0.9.8.1107, an unauthenticated attacker can use %00 bytes to cause /user/loader.php to register an arbitrary API key, as demonstrated by a /user/loader.php?api=1&scripts= .%00./.%00./api/account_new_create&acc=guadaapi URI. Any number of %00 instances can be used, e.g., .%00%00%00./.%00%00%00./api/account_new_create could also be used for the scripts parameter.
Affected products
- CentOS Web Panel: before 0.9.8.1107 — fixed in 0.9.8.1107
How to fix
Upgrade to a fixed version: CentOS Web Panel 0.9.8.1107. Check the vendor advisory for mitigations.
References
- https://control-webpanel.com/changelog
- https://octagon.net/blog/2022/01/22/cve-2021-45467-cwp-centos-web-panel-preauth-rce/
- https://control-webpanel.com/changelog
- https://octagon.net/blog/2022/01/22/cve-2021-45467-cwp-centos-web-panel-preauth-rce/
Get alerted when CVE-2021-45467 or the next vulnerability affects your stack