What’s Vulnerable › Vulnerabilities
CVE-2021-45526
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects EX6000 before 1.0.0.38, EX6120 before 1.0.0.48, EX6130 before 1.0.0.30, R6300v2 before 1.0.4.52, R6400 before 1.0.1.52, R7000 before 1.0.11.126, R7900 before 1.0.4.30, R8000 before 1.0.4.52, R7000P before 1.3.2.124, R8000P before 1.4.1.50, RAX80 before 1.0.3.88, R6900P before 1.3.2.124, R7900P before 1.4.1.50, and RAX75 before 1.0.3.88.
Affected products
- NETGEAR Ex6000 Firmware: before 1.0.0.38 — fixed in 1.0.0.38
- NETGEAR EX6120: before 1.0.0.48 — fixed in 1.0.0.48
- NETGEAR Ex6130 Firmware: before 1.0.0.30 — fixed in 1.0.0.30
- NETGEAR R6300V2 Firmware: before 1.0.4.52 — fixed in 1.0.4.52
- NETGEAR R6400 Firmware: before 1.0.1.52 — fixed in 1.0.1.52
- NETGEAR R6900P Firmware: before 1.3.2.124 — fixed in 1.3.2.124
- NETGEAR R7000: before 1.0.11.126 — fixed in 1.0.11.126
- NETGEAR R7000P: before 1.3.2.124 — fixed in 1.3.2.124
- NETGEAR R7900 Firmware: before 1.0.4.30 — fixed in 1.0.4.30
- NETGEAR R7900P Firmware: before 1.4.1.50 — fixed in 1.4.1.50
- NETGEAR R8000 Firmware: before 1.0.4.52 — fixed in 1.0.4.52
- NETGEAR R8000P Firmware: before 1.4.1.50 — fixed in 1.4.1.50
- NETGEAR Rax75 Firmware: before 1.0.3.88 — fixed in 1.0.3.88
- NETGEAR Rax80 Firmware: before 1.0.3.88 — fixed in 1.0.3.88
How to fix
Upgrade to a fixed version: NETGEAR Ex6000 Firmware 1.0.0.38; NETGEAR EX6120 1.0.0.48; NETGEAR Ex6130 Firmware 1.0.0.30; NETGEAR R6300V2 Firmware 1.0.4.52; NETGEAR R6400 Firmware 1.0.1.52; NETGEAR R6900P Firmware 1.3.2.124; NETGEAR R7000 1.0.11.126; NETGEAR R7000P 1.3.2.124; NETGEAR R7900 Firmware 1.0.4.30; NETGEAR R7900P Firmware 1.4.1.50; NETGEAR R8000 Firmware 1.0.4.52; NETGEAR R8000P Firmware 1.4.1.50. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064446/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Some-Routers-and-Extenders-PSV-2019-0078
- https://kb.netgear.com/000064446/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Some-Routers-and-Extenders-PSV-2019-0078
Get alerted when CVE-2021-45526 or the next vulnerability affects your stack