What’s Vulnerable › Vulnerabilities

CVE-2021-45527

Description

Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects D6220 before 1.0.0.68, D6400 before 1.0.0.102, D7000v2 before 1.0.0.66, D8500 before 1.0.3.58, DC112A before 1.0.0.54, EX7000 before 1.0.1.94, EX7500 before 1.0.0.72, R6250 before 1.0.4.48, R6300v2 before 1.0.4.52, R6400 before 1.0.1.70, R6400v2 before 1.0.4.102, R6700v3 before 1.0.4.102, R7000 before 1.0.11.116, R7100LG before 1.0.0.64, R7850 before 1.0.5.68, R7900 before 1.0.4.30, R7960P before 1.4.1.68, R8000 before 1.0.4.52, RAX200 before 1.0.2.88, RBS40V before 2.6.2.4, RS400 before 1.5.1.80, XR300 before 1.0.3.56, R7000P before 1.3.2.124, R8000P before 1.4.1.68, R8500 before 1.0.2.144, RAX80 before 1.0.3.102, R6900P before 1.3.2.124, R7900P before 1.4.1.68, R8300 before 1.0.2.144, RAX75 before 1.0.3.102, RBR750 before 3.2.17.12, RBR850 before 3.2.17.12, RBS750 before 3.2.17.12, RBS850 before 3.2.17.12, RBK752 before 3.2.17.12, and RBK852 before 3.2.17.12.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.68; Netgear D6400 1.0.0.102; NETGEAR D7000V2 Firmware 1.0.0.66; NETGEAR D8500 Firmware 1.0.3.58; NETGEAR Dc112A Firmware 1.0.0.54; NETGEAR Ex7000 Firmware 1.0.1.94; NETGEAR Ex7500 Firmware 1.0.0.72; NETGEAR R6250 Firmware 1.0.4.48; NETGEAR R6300V2 Firmware 1.0.4.52; NETGEAR R6400 Firmware 1.0.1.70; NETGEAR R6400V2 Firmware 1.0.4.102; NETGEAR R6700V3 Firmware 1.0.4.102. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-45527 or the next vulnerability affects your stack