What’s Vulnerable › Vulnerabilities
CVE-2021-45528
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects R6300v2 before 1.0.4.52, R6400 before 1.0.1.52, R6900 before 1.0.2.8, R7000 before 1.0.9.88, R7900 before 1.0.3.18, R8000 before 1.0.4.46, R7900P before 1.4.1.50, R8000P before 1.4.1.50, RAX75 before 1.0.3.88, RAX80 before 1.0.3.88, and WNR3500Lv2 before 1.2.0.62.
Affected products
- NETGEAR R6300V2 Firmware: through 1.0.4.52
- NETGEAR R6400 Firmware: before 1.0.1.52 — fixed in 1.0.1.52
- NETGEAR R6900 Firmware: before 1.0.2.8 — fixed in 1.0.2.8
- NETGEAR R7000: before 1.0.9.88 — fixed in 1.0.9.88
- NETGEAR R7900 Firmware: before 1.0.3.18 — fixed in 1.0.3.18
- NETGEAR R7900P Firmware: before 1.4.1.50 — fixed in 1.4.1.50
- NETGEAR R8000 Firmware: before 1.0.4.46 — fixed in 1.0.4.46
- NETGEAR R8000P Firmware: before 1.4.1.50 — fixed in 1.4.1.50
- NETGEAR Rax75 Firmware: before 1.0.3.88 — fixed in 1.0.3.88
- NETGEAR Rax80 Firmware: before 1.0.3.88 — fixed in 1.0.3.88
- NETGEAR Wnr3500Lv2 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
How to fix
Upgrade to a fixed version: NETGEAR R6400 Firmware 1.0.1.52; NETGEAR R6900 Firmware 1.0.2.8; NETGEAR R7000 1.0.9.88; NETGEAR R7900 Firmware 1.0.3.18; NETGEAR R7900P Firmware 1.4.1.50; NETGEAR R8000 Firmware 1.0.4.46; NETGEAR R8000P Firmware 1.4.1.50; NETGEAR Rax75 Firmware 1.0.3.88; NETGEAR Rax80 Firmware 1.0.3.88; NETGEAR Wnr3500Lv2 Firmware 1.2.0.62. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064057/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2019-0069
- https://kb.netgear.com/000064057/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2019-0069
Get alerted when CVE-2021-45528 or the next vulnerability affects your stack