What’s Vulnerable › Vulnerabilities
CVE-2021-45529
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an authenticated user. This affects CBR40 before 2.3.5.12, D7000v2 before 1.0.0.66, D8500 before 1.0.3.58, R6400 before 1.0.1.70, R7000 before 1.0.11.126, R6900P before 1.3.2.124, R7000P before 1.3.2.124, R7900 before 1.0.4.30, R8000 before 1.0.4.52, and WNR3500Lv2 before 1.2.0.62.
Affected products
- NETGEAR Cbr40 Firmware: before 2.3.5.12 — fixed in 2.3.5.12
- NETGEAR D7000V2 Firmware: before 1.0.0.66 — fixed in 1.0.0.66
- NETGEAR D8500 Firmware: before 1.0.3.58 — fixed in 1.0.3.58
- NETGEAR R6400 Firmware: before 1.0.1.70 — fixed in 1.0.1.70
- NETGEAR R6900P Firmware: before 1.3.2.124 — fixed in 1.3.2.124
- NETGEAR R7000: before 1.0.11.126 — fixed in 1.0.11.126
- NETGEAR R7000P: before 1.3.2.124 — fixed in 1.3.2.124
- NETGEAR R7900 Firmware: before 1.0.4.30 — fixed in 1.0.4.30
- NETGEAR R8000 Firmware: before 1.0.4.52 — fixed in 1.0.4.52
- NETGEAR Wnr3500Lv2 Firmware: before 1.2.0.62 — fixed in 1.2.0.62
How to fix
Upgrade to a fixed version: NETGEAR Cbr40 Firmware 2.3.5.12; NETGEAR D7000V2 Firmware 1.0.0.66; NETGEAR D8500 Firmware 1.0.3.58; NETGEAR R6400 Firmware 1.0.1.70; NETGEAR R6900P Firmware 1.3.2.124; NETGEAR R7000 1.0.11.126; NETGEAR R7000P 1.3.2.124; NETGEAR R7900 Firmware 1.0.4.30; NETGEAR R8000 Firmware 1.0.4.52; NETGEAR Wnr3500Lv2 Firmware 1.2.0.62. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064058/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2019-0077
- https://kb.netgear.com/000064058/Security-Advisory-for-Post-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2019-0077
Get alerted when CVE-2021-45529 or the next vulnerability affects your stack