What’s Vulnerable › Vulnerabilities
CVE-2021-45552
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects D7800 before 1.0.1.58, R7500v2 before 1.0.3.48, R7800 before 1.0.2.68, R8900 before 1.0.5.2, R9000 before 1.0.5.2, RAX120 before 1.0.1.108, and XR700 before 1.0.1.20.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.58 — fixed in 1.0.1.58
- NETGEAR R7500V2 Firmware: before 1.0.3.48 — fixed in 1.0.3.48
- NETGEAR R7800 Firmware: before 1.0.2.68 — fixed in 1.0.2.68
- NETGEAR R8900 Firmware: before 1.0.5.2 — fixed in 1.0.5.2
- NETGEAR R9000 Firmware: before 1.0.5.2 — fixed in 1.0.5.2
- NETGEAR Rax120 Firmware: through 1.0.1.108
- NETGEAR Xr700 Firmware: before 1.0.1.20 — fixed in 1.0.1.20
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.58; NETGEAR R7500V2 Firmware 1.0.3.48; NETGEAR R7800 Firmware 1.0.2.68; NETGEAR R8900 Firmware 1.0.5.2; NETGEAR R9000 Firmware 1.0.5.2; NETGEAR Xr700 Firmware 1.0.1.20. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064071/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2019-0199
- https://kb.netgear.com/000064071/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2019-0199
Get alerted when CVE-2021-45552 or the next vulnerability affects your stack