What’s Vulnerable › Vulnerabilities
CVE-2021-45554
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects R6400 before 1.0.1.74, R6400v2 before 1.0.4.118, R6700v3 before 1.0.4.118, R7000 before 1.0.11.126, R6900P before 1.3.3.140, R7000P before 1.3.3.140, and R8000 before 1.0.4.74.
Affected products
- NETGEAR R6400 Firmware: before 1.0.1.74 — fixed in 1.0.1.74
- NETGEAR R6400V2 Firmware: before 1.0.4.118 — fixed in 1.0.4.118
- NETGEAR R6700V3 Firmware: before 1.0.4.118 — fixed in 1.0.4.118
- NETGEAR R6900P Firmware: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR R7000: before 1.0.11.126 — fixed in 1.0.11.126
- NETGEAR R7000P: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR R8000 Firmware: before 1.0.4.74 — fixed in 1.0.4.74
How to fix
Upgrade to a fixed version: NETGEAR R6400 Firmware 1.0.1.74; NETGEAR R6400V2 Firmware 1.0.4.118; NETGEAR R6700V3 Firmware 1.0.4.118; NETGEAR R6900P Firmware 1.3.3.140; NETGEAR R7000 1.0.11.126; NETGEAR R7000P 1.3.3.140; NETGEAR R8000 Firmware 1.0.4.74. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064119/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2020-0187
- https://kb.netgear.com/000064119/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-PSV-2020-0187
Get alerted when CVE-2021-45554 or the next vulnerability affects your stack