What’s Vulnerable › Vulnerabilities
CVE-2021-45602
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-78
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects D7800 before 1.0.1.66, EX2700 before 1.0.1.68, WN3000RPv2 before 1.0.0.90, WN3000RPv3 before 1.0.2.100, LBR1020 before 2.6.5.20, LBR20 before 2.6.5.32, R6700AX before 1.0.10.110, R7800 before 1.0.2.86, R8900 before 1.0.5.38, R9000 before 1.0.5.38, RAX10 before 1.0.10.110, RAX120v1 before 1.2.3.28, RAX120v2 before 1.2.3.28, RAX70 before 1.0.10.110, RAX78 before 1.0.10.110, XR450 before 2.3.2.130, XR500 before 2.3.2.130, and XR700 before 1.0.1.46.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.66 — fixed in 1.0.1.66
- NETGEAR Ex2700 Firmware: before 1.0.1.68 — fixed in 1.0.1.68
- NETGEAR Lbr1020 Firmware: before 2.6.5.20 — fixed in 2.6.5.20
- NETGEAR Lbr20 Firmware: before 2.6.5.32 — fixed in 2.6.5.32
- NETGEAR R6700Ax Firmware: before 1.0.10.110 — fixed in 1.0.10.110
- NETGEAR R7800 Firmware: before 1.0.2.86 — fixed in 1.0.2.86
- NETGEAR R8900 Firmware: before 1.0.5.38 — fixed in 1.0.5.38
- NETGEAR R9000 Firmware: before 1.0.5.38 — fixed in 1.0.5.38
- NETGEAR Rax10 Firmware: before 1.0.10.110 — fixed in 1.0.10.110
- NETGEAR Rax120V1 Firmware: before 1.2.3.28 — fixed in 1.2.3.28
- NETGEAR Rax120V2 Firmware: before 1.2.3.28 — fixed in 1.2.3.28
- NETGEAR Rax70 Firmware: before 1.0.10.110 — fixed in 1.0.10.110
- NETGEAR Rax78 Firmware: before 1.0.10.110 — fixed in 1.0.10.110
- NETGEAR Wn3000Rpv2 Firmware: before 1.0.0.90 — fixed in 1.0.0.90
- NETGEAR Wn3000Rpv3 Firmware: before 1.0.2.100 — fixed in 1.0.2.100
- NETGEAR Xr450 Firmware: before 2.3.2.130 — fixed in 2.3.2.130
- NETGEAR Xr500 Firmware: before 2.3.2.130 — fixed in 2.3.2.130
- NETGEAR Xr700 Firmware: before 1.0.1.46 — fixed in 1.0.1.46
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.66; NETGEAR Ex2700 Firmware 1.0.1.68; NETGEAR Lbr1020 Firmware 2.6.5.20; NETGEAR Lbr20 Firmware 2.6.5.32; NETGEAR R6700Ax Firmware 1.0.10.110; NETGEAR R7800 Firmware 1.0.2.86; NETGEAR R8900 Firmware 1.0.5.38; NETGEAR R9000 Firmware 1.0.5.38; NETGEAR Rax10 Firmware 1.0.10.110; NETGEAR Rax120V1 Firmware 1.2.3.28; NETGEAR Rax120V2 Firmware 1.2.3.28; NETGEAR Rax70 Firmware 1.0.10.110. Check the vendor advisory for mitigations.
References
- https://immersivelabs.com/resources/blog/netgear-vulnerabilities-could-put-small-business-routers-at-risk/
- https://kb.netgear.com/000064407/Security-Advisory-for-Post-Authentication-Command-Injection-Sensitive-Information-Disclosure-on-Multiple-Products-PSV-2021-0169-PSV-2021-0171
- https://immersivelabs.com/resources/blog/netgear-vulnerabilities-could-put-small-business-routers-at-risk/
- https://kb.netgear.com/000064407/Security-Advisory-for-Post-Authentication-Command-Injection-Sensitive-Information-Disclosure-on-Multiple-Products-PSV-2021-0169-PSV-2021-0171
Get alerted when CVE-2021-45602 or the next vulnerability affects your stack