What’s Vulnerable › Vulnerabilities
CVE-2021-45605
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects R6400 before 1.0.1.68, R7000 before 1.0.11.116, R6900P before 1.3.3.140, R7000P before 1.3.3.140, R7900 before 1.0.4.38, RAX75 before 1.0.3.102, RAX80 before 1.0.3.102, and XR300 before 1.0.3.50.
Affected products
- NETGEAR R6400 Firmware: before 1.0.1.68 — fixed in 1.0.1.68
- NETGEAR R6900P Firmware: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR R7000: before 1.0.11.116 — fixed in 1.0.11.116
- NETGEAR R7000P: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR R7900 Firmware: before 1.0.4.38 — fixed in 1.0.4.38
- NETGEAR Rax75 Firmware: before 1.0.3.102 — fixed in 1.0.3.102
- NETGEAR Rax80 Firmware: before 1.0.3.102 — fixed in 1.0.3.102
- NETGEAR Xr300 Firmware: before 1.0.3.50 — fixed in 1.0.3.50
How to fix
Upgrade to a fixed version: NETGEAR R6400 Firmware 1.0.1.68; NETGEAR R6900P Firmware 1.3.3.140; NETGEAR R7000 1.0.11.116; NETGEAR R7000P 1.3.3.140; NETGEAR R7900 Firmware 1.0.4.38; NETGEAR Rax75 Firmware 1.0.3.102; NETGEAR Rax80 Firmware 1.0.3.102; NETGEAR Xr300 Firmware 1.0.3.50. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064072/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2019-0214
- https://kb.netgear.com/000064072/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2019-0214
Get alerted when CVE-2021-45605 or the next vulnerability affects your stack