What’s Vulnerable › Vulnerabilities
CVE-2021-45607
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects R6400v2 before 1.0.4.118, R6700v3 before 1.0.4.118, R6900P before 1.3.3.140, R7000 before 1.0.11.126, R7000P before 1.3.3.140, RAX200 before 1.0.5.126, RAX75 before 1.0.5.126, and RAX80 before 1.0.5.126.
Affected products
- NETGEAR R6400V2 Firmware: before 1.0.4.118 — fixed in 1.0.4.118
- NETGEAR R6700V3 Firmware: before 1.0.4.118 — fixed in 1.0.4.118
- NETGEAR R6900P Firmware: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR R7000: before 1.0.11.126 — fixed in 1.0.11.126
- NETGEAR R7000P: before 1.3.3.140 — fixed in 1.3.3.140
- NETGEAR Rax200 Firmware: before 1.0.5.126 — fixed in 1.0.5.126
- NETGEAR Rax75 Firmware: before 1.0.5.126 — fixed in 1.0.5.126
- NETGEAR Rax80 Firmware: before 1.0.5.126 — fixed in 1.0.5.126
How to fix
Upgrade to a fixed version: NETGEAR R6400V2 Firmware 1.0.4.118; NETGEAR R6700V3 Firmware 1.0.4.118; NETGEAR R6900P Firmware 1.3.3.140; NETGEAR R7000 1.0.11.126; NETGEAR R7000P 1.3.3.140; NETGEAR Rax200 Firmware 1.0.5.126; NETGEAR Rax75 Firmware 1.0.5.126; NETGEAR Rax80 Firmware 1.0.5.126. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064531/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2021-0128
- https://kb.netgear.com/000064531/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2021-0128
Get alerted when CVE-2021-45607 or the next vulnerability affects your stack