What’s Vulnerable › Vulnerabilities
CVE-2021-45608
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-190
Description
Certain D-Link, Edimax, NETGEAR, TP-Link, Tenda, and Western Digital devices are affected by an integer overflow by an unauthenticated attacker. Remote code execution from the WAN interface (TCP port 20005) cannot be ruled out; however, exploitability was judged to be of "rather significant complexity" but not "impossible." The overflow is in SoftwareBus_dispatchNormalEPMsgOut in the KCodes NetUSB kernel module. Affected NETGEAR devices are D7800 before 1.0.1.68, R6400v2 before 1.0.4.122, and R6700v3 before 1.0.4.122.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.68 — fixed in 1.0.1.68
- NETGEAR R6400V2 Firmware: before 1.0.4.122 — fixed in 1.0.4.122
- NETGEAR R6700V3 Firmware: before 1.0.4.122 — fixed in 1.0.4.122
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.68; NETGEAR R6400V2 Firmware 1.0.4.122; NETGEAR R6700V3 Firmware 1.0.4.122. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064437/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Multiple-Products-PSV-2021-0278
- https://www.sentinelone.com/labs/cve-2021-45608-netusb-rce-flaw-in-millions-of-end-user-routers/
- https://kb.netgear.com/000064437/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Multiple-Products-PSV-2021-0278
- https://www.sentinelone.com/labs/cve-2021-45608-netusb-rce-flaw-in-millions-of-end-user-routers/
Get alerted when CVE-2021-45608 or the next vulnerability affects your stack