What’s Vulnerable › Vulnerabilities
CVE-2021-45609
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects D8500 before 1.0.3.58, R6250 before 1.0.4.48, R7000 before 1.0.11.116, R7100LG before 1.0.0.64, R7900 before 1.0.4.38, R8300 before 1.0.2.144, R8500 before 1.0.2.144, XR300 before 1.0.3.68, R7000P before 1.3.2.132, and R6900P before 1.3.2.132.
Affected products
- NETGEAR D8500 Firmware: before 1.0.3.58 — fixed in 1.0.3.58
- NETGEAR R6250 Firmware: before 1.0.4.48 — fixed in 1.0.4.48
- NETGEAR R6900P Firmware: before 1.3.2.132 — fixed in 1.3.2.132
- NETGEAR R7000: before 1.0.11.116 — fixed in 1.0.11.116
- NETGEAR R7000P: before 1.3.2.132 — fixed in 1.3.2.132
- NETGEAR R7100Lg Firmware: before 1.0.0.64 — fixed in 1.0.0.64
- NETGEAR R7900 Firmware: before 1.0.4.38 — fixed in 1.0.4.38
- NETGEAR R8300 Firmware: before 1.0.2.144 — fixed in 1.0.2.144
- NETGEAR R8500 Firmware: before 1.0.2.144 — fixed in 1.0.2.144
- NETGEAR Xr300 Firmware: before 1.0.3.68 — fixed in 1.0.3.68
How to fix
Upgrade to a fixed version: NETGEAR D8500 Firmware 1.0.3.58; NETGEAR R6250 Firmware 1.0.4.48; NETGEAR R6900P Firmware 1.3.2.132; NETGEAR R7000 1.0.11.116; NETGEAR R7000P 1.3.2.132; NETGEAR R7100Lg Firmware 1.0.0.64; NETGEAR R7900 Firmware 1.0.4.38; NETGEAR R8300 Firmware 1.0.2.144; NETGEAR R8500 Firmware 1.0.2.144; NETGEAR Xr300 Firmware 1.0.3.68. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064483/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2020-0274
- https://kb.netgear.com/000064483/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2020-0274
Get alerted when CVE-2021-45609 or the next vulnerability affects your stack