What’s Vulnerable › Vulnerabilities

CVE-2021-45610

Description

Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects D6220 before 1.0.0.66, D6400 before 1.0.0.100, D7000v2 before 1.0.0.66, D8500 before 1.0.3.58, DC112A before 1.0.0.52, DGN2200v4 before 1.0.0.118, EAX80 before 1.0.1.64, R6250 before 1.0.4.48, R7000 before 1.0.11.110, R7100LG before 1.0.0.72, R7900 before 1.0.4.30, R7960P before 1.4.1.64, R8000 before 1.0.4.62, RAX200 before 1.0.3.106, RS400 before 1.5.1.80, XR300 before 1.0.3.68, R6400v2 before 1.0.4.106, R7000P before 1.3.2.132, R8000P before 1.4.1.64, RAX20 before 1.0.2.82, RAX45 before 1.0.2.82, RAX80 before 1.0.3.106, R6700v3 before 1.0.4.106, R6900P before 1.3.2.132, R7900P before 1.4.1.64, RAX15 before 1.0.2.82, RAX50 before 1.0.2.82, and RAX75 before 1.0.3.106.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.66; Netgear D6400 1.0.0.100; NETGEAR D7000V2 Firmware 1.0.0.66; NETGEAR D8500 Firmware 1.0.3.58; NETGEAR Dc112A Firmware 1.0.0.52; NETGEAR Dgn2200V4 Firmware 1.0.0.118; NETGEAR Eax80 Firmware 1.0.1.64; NETGEAR R6250 Firmware 1.0.4.48; NETGEAR R6400V2 Firmware 1.0.4.106; NETGEAR R6700V3 Firmware 1.0.4.106; NETGEAR R6900P Firmware 1.3.2.132; NETGEAR R7000 1.0.11.110. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-45610 or the next vulnerability affects your stack