What’s Vulnerable › Vulnerabilities
CVE-2021-45611
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects DC112A before 1.0.0.52, R6400 before 1.0.1.68, RAX200 before 1.0.3.106, WNDR3400v3 before 1.0.1.38, XR300 before 1.0.3.68, R8500 before 1.0.2.144, RAX75 before 1.0.3.106, R8300 before 1.0.2.144, and RAX80 before 1.0.3.106.
Affected products
- NETGEAR Dc112A Firmware: before 1.0.0.52 — fixed in 1.0.0.52
- NETGEAR R6400 Firmware: before 1.0.1.68 — fixed in 1.0.1.68
- NETGEAR R8300 Firmware: before 1.0.2.144 — fixed in 1.0.2.144
- NETGEAR R8500 Firmware: before 1.0.2.144 — fixed in 1.0.2.144
- NETGEAR Rax200 Firmware: before 1.0.3.106 — fixed in 1.0.3.106
- NETGEAR Rax75 Firmware: before 1.0.3.106 — fixed in 1.0.3.106
- NETGEAR Rax80 Firmware: before 1.0.3.106 — fixed in 1.0.3.106
- NETGEAR Wndr3400V3 Firmware: before 1.0.1.38 — fixed in 1.0.1.38
- NETGEAR Xr300 Firmware: before 1.0.3.68 — fixed in 1.0.3.68
How to fix
Upgrade to a fixed version: NETGEAR Dc112A Firmware 1.0.0.52; NETGEAR R6400 Firmware 1.0.1.68; NETGEAR R8300 Firmware 1.0.2.144; NETGEAR R8500 Firmware 1.0.2.144; NETGEAR Rax200 Firmware 1.0.3.106; NETGEAR Rax75 Firmware 1.0.3.106; NETGEAR Rax80 Firmware 1.0.3.106; NETGEAR Wndr3400V3 Firmware 1.0.1.38; NETGEAR Xr300 Firmware 1.0.3.68. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064488/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2020-0323
- https://kb.netgear.com/000064488/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-PSV-2020-0323
Get alerted when CVE-2021-45611 or the next vulnerability affects your stack