What’s Vulnerable › Vulnerabilities
CVE-2021-45623
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-26 · updated 2026-06-17
- Weakness: CWE-77
Description
Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects R7800 before 1.0.2.74, R9000 before 1.0.5.2, and XR500 before 2.3.2.66.
Affected products
- NETGEAR R7800 Firmware: before 1.0.2.74 — fixed in 1.0.2.74
- NETGEAR R9000 Firmware: before 1.0.5.2 — fixed in 1.0.5.2
- NETGEAR Xr500 Firmware: before 2.3.2.66 — fixed in 2.3.2.66
How to fix
Upgrade to a fixed version: NETGEAR R7800 Firmware 1.0.2.74; NETGEAR R9000 Firmware 1.0.5.2; NETGEAR Xr500 Firmware 2.3.2.66. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000064449/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-PSV-2019-0203
- https://kb.netgear.com/000064449/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-PSV-2019-0203
Get alerted when CVE-2021-45623 or the next vulnerability affects your stack